Article delegate-en/5011 of [1-5169] on the server localhost:119
  upper oldest olders older1 this newer1 newers latest
search
[Top/Up] [oldest] - [Older+chunk] - [Newer+chunk] - [newest + Check]

Newsgroups: mail-lists.delegate-en

[DeleGate-En] delegate: socksmux doesn't work when running in background
02 Feb 2012 02:46:58 GMT Renaud Bompuis <psmjqbdyi-7vqijqq7wcgr.ml@ml.delegate.org>
Oriental Blue Consulting Ltd


Hi,
I am trying to make delegate work as a multiplexed SOCKS tunnel, as 
described here:
http://www.delegate.org/delegate/SOCKS/sockmux/

Basically, I want to use 2 servers to relay proxy data efficiently (to 
bypass blocking of websites in an oppressive country):
- a server run on a site in OppressiveCountry, used by local users as a 
SOCKS5 proxy in their browsers.
- This server then sends all proxy requests to a gateway server outside 
of OppressiveCountry.

Our configuration is as highlighted in the docs above:
The local proxy configuration file, in OppressiveCountry:

    RELIABLE="*"
    ADMIN="xxx@xxx.."
    -P12345
    SOCKMUX=1.2.3.4:8000:con
    SOCKS=1.2.3.4:8778
    SERVER=socks

The remote gateway proxy, outside of OppressiveCountry (IP:1.2.3.4):

    RELIABLE="*"
    PERMIT="*:*:*"
    ADMIN="xxx@xxx.."
    -P8778
    SOCKMUX=1.2.3.4:8000:acc
    SERVER=socks

It works fine when in debug mode, using -v on both servers:
delegated -v +=/etc/delegated.conf

But the servers are throwing errors and refuse connection when running 
going to the background.
In particular, we get this line:
(UNIX) 10:29:53.270 [9497] #### PrivateSox Failure  ####

The only difference is the fact that we run in debug mode.
I can't seem to find out why delegate would behave differently in 
background mode.
There doesn't look to be any other errors reported in the log file.

Thank you for any help on this.
Take care,

Renaud Bompuis


  admin search upper oldest olders older1 this newer1 newers latest
[Top/Up] [oldest] - [Older+chunk] - [Newer+chunk] - [newest + Check]
@_@V