Article delegate-en/63 of [1-5169] on the server localhost:119
  upper oldest olders older1 this newer1 newers latest
search
[Top/Up] [oldest] - [Older+chunk] - [Newer+chunk] - [newest + Check]

Newsgroups: mail-lists.delegate-en

[DeleGate-En] delegate ftp loose connection
08 Sep 1998 13:33:15 GMT "Piero Berritta" <ph4aabdyi-h5qfbmz6rw3r.ml@ml.delegate.org>


Hi,
I'm still testing delegate to create a tunnel ssl between a client and a
server ftp not ssl using the following comand lines:

Client side:
delegated -P21 FSV="sslway -co" SERVER=ftp://ftp-server-name:8021

Server side:
delegated -P8021 FCL="sslway -ac" SERVER=ftp://ftp-server-name:21

using Windows machines all works perfectly (strange thing!). On the
contrary, using LINUX machines, I'm able to establish the connection but as
soon as I issue a dir command I loose the connection. This happens both with
ssl and without.
The log of delegate server side is the following:

09/08 08:11:15.70 [520] 1+0/5: FTP-CACHE: LIST [] = [][]:0
09/08 08:11:15.70 [520] 1+0/5: -- XDC to PASV
09/08 08:11:15.70 [520] 1+0/5: --- XDC data_relay SERVER (RECV).
09/08 08:11:15.71 [520] 1+0/5: -- Tried freadTIMEOUT() for EOF file.
09/08 08:11:15.71 [520] 1+0/5: -- Tried freadTIMEOUT() for EOF file.
09/08 08:11:15.71 [520] 1+0/5: E-A: ABORT: caught SIGSEGV [11]

It could be a problem in the configuration of ftp server (Wu-ftpd) or
something else ?
thank you for any help (a particular thank to Yutaka for previous answers)

Piero


  admin search upper oldest olders older1 this newer1 newers latest
[Top/Up] [oldest] - [Older+chunk] - [Newer+chunk] - [newest + Check]
@_@V