Article delegate-en/809 of [1-5169] on the server localhost:119
  upper oldest olders older1 this newer1 newers latest
search
[Top/Up] [oldest] - [Older+chunk] - [Newer+chunk] - [newest + Check]
[Reference:<20000524104041.A387@neelix.achenbach.rising-systems.de>]
Newsgroups: mail-lists.delegate-en

[DeleGate-En] Re: Problems reaching different servers with same IP
26 May 2000 05:58:37 GMT ysato@etl.go.jp (Yutaka Sato)


In message <20000524104041.A387@neelix.achenbach.rising-systems.de>
on 05/24/00(17:40:41) you Heiner Lennackers <pdubqbdyi-bfkmicgiir3r.ml@ml.delegate.org> wrote:
 |i am using the following startup command:
 |
 |   delegated -P80 SERVER=http \
 |                  EXPIRE=1d \
 |                  CRON="0 * * * * -expire 2d" \
 |                  PROTOLOG \
 |                  RESOLV=dns \
 |                  REACHABLE="!www.skyinet.net,!206.101.197.226" \
 |                  RELIABLE=".localnet"
 |
 |Here an example what happens:
 |	if i ask the delegate for "http://www.rising-systems.com/" 
 |        delegate sends the request to the server using the ip address,

How are you sure about it?
You will see the request message which is sent out to the server
with optiosn like:

  -f FTOSV=-tee-n

 |	but this is a virtual server. On the same physical server server 
 |        are some other http-sites too, e.g.  http://www.bytewurm.de/ . 
 |        The server uses the name to decide, so if delegate uses the ip 
 |        to address the server i never get a valid answer.

Using your configuration with above options I saw following output
shown for each site, getting proper response for each virtual host
which is specified in "Host:" field in request.  (I used Mozilla/4
which specifies this DeleGate as its HTTP proxy in this case)

     1  GET / HTTP/1.1
     2  Connection: keep-alive
     3  Via: 1.1 - (DeleGate/6.1.12)
     4  User-Agent: Mozilla/4.72 [en] (Windows NT 5.0; U)
     5  Pragma: no-cache
     6  Host: www.rising-systems.com
     7  Accept: image/gif, image/x-xbitmap, image/jpeg, image/pjpeg, image/png, */*
     8  Accept-Encoding: gzip
     9  Accept-Language: en
    10  Accept-Charset: iso-8859-1,*,utf-8
    11  If-Modified-Since: Mon, 22 May 2000 08:19:36 GMT; length=17683
    12

     1  GET / HTTP/1.1
     2  Connection: keep-alive
     3  Via: 1.1 - (DeleGate/6.1.12)
     4  User-Agent: Mozilla/4.72 [en] (Windows NT 5.0; U)
     5  Pragma: no-cache
     6  Host: www.bytewurm.de
     7  Accept: image/gif, image/x-xbitmap, image/jpeg, image/pjpeg, image/png, */*
     8  Accept-Encoding: gzip
     9  Accept-Language: en
    10  Accept-Charset: iso-8859-1,*,utf-8
    11  If-Modified-Since: Thu, 06 Apr 2000 10:44:23 GMT; length=2078
    12


 |On the pervious used delegated 5.9.3 i use the sme options except that
 |the server options is set to: SERVER=http://-/-/
 |If i use this option with the delegated 6.1.10 i get no answer at all.

No answer for what ?
I could use your configuration with SERVER=http://-/-/ without problem
to get http://www.bytewurm.de for example, like follows:

05/26 14:50:01.73 [2586] 2+0: -- Fork(SequentialServer): 2573 -> 2586
05/26 14:50:01.79 [2586] 2+1: (1) accepted [49] -@[xxx.31.200.192]xxx.etl.go.jp:1477 (0.071s)(2)
05/26 14:50:01.82 [2586] 2+1: Proxy: host=xxx.etl.go.jp; User-Agent: Mozilla/4.72 [en] (Windows NT 5.0; U); DIRECT
05/26 14:50:01.82 [2586] 2+1: HCKA:[0] Keep-Alive; host=xxx.etl.go.jp; (User-Agent: Mozilla/4.72 [en] (Windows NT 5.0; U))
05/26 14:50:01.83 [2586] 2+1: REQUEST - GET http://www.bytewurm.de/ HTTP/1.0^M
05/26 14:50:01.84 [2586] 2+1: ## hostIFto xxx.31.200.192 < 0.0.0.0 (ffffff00)
05/26 14:50:01.84 [2586] 2+1: PATH> http://www.bytewurm.de:80!wall.etl.go.jp:9999!xxx.etl.go.jp:1477!anonymous@xxx.etl.go.jp;959320201
05/26 14:50:01.84 [2586] 2+1: REQUEST = [http://www.bytewurm.de/] GET / HTTP/1.0^M
05/26 14:50:01.87 [2586] 2+1: [0.02,-1][HTTP cache-NONE] /XXX/delegate/cache/http/www.bytewurm.de/=
05/26 14:50:02.54 [2586] 2+1: ConnectToServer connected [18] {195.212.87.9:80 <- 192.50.77.225:34752} [0.387s]
05/26 14:50:02.54 [2586] 2+1: HTTP => (www.bytewurm.de:80) GET / HTTP/1.0^M
05/26 14:50:02.55 [2586] 2+1: #HT11 FORCE HTTP/1.1 or Connection:keep-alive
05/26 14:50:02.95 [2586] 2+1: #HT11 SERVER ver[HTTP/1.1] conn[Keep-Alive]
05/26 14:50:02.95 [2586] 2+1: #HT11 server KEEP-ALIVE
05/26 14:50:02.95 [2586] 2+1: HTTP/1.1 200 Content-{Type:text/html Encoding:[/] Leng:2078} Server:Apache/1.3.12 (Unix)
05/26 14:50:04.06 [2586] 2+1: Content-Length: 2078 -> 2078 (2418 - 340)
05/26 14:50:04.11 [2586] 2+1: HTTP transmitted: 286head+2078/2078body=>2078txt+0bin->2078/2078, 13i/2o/0f/1.6
05/26 14:50:04.11 [2586] 2+1: 2340 bytes written to [/XXX/delegate/cache/http/www.bytewurm.de/=]
05/26 14:50:04.14 [2586] 2+1: #HT11 putServ(19/20) www.bytewurm.de:80
05/26 14:50:11.36 [2586] 2+1/1: HCKA:[1] closed -- t:timeout: 7
05/26 14:50:11.37 [2586] 2+1/1: disconnected [49] -@[xxx.31.200.192]xxx.etl.go.jp:1477 (9.651s)(1)


Cheers,
Yutaka
--
Yutaka Sato <ysato@etl.go.jp> http://www.etl.go.jp/~ysato/   @ @ 
Computer Science Division, Electrotechnical Laboratory      ( - )
1-1-4 Umezono, Tsukuba, Ibaraki, 305-8568 Japan            _<   >_

In message <20000524104041.A387@neelix.achenbach.rising-systems.de>
on 05/24/00(17:40:41) you Heiner Lennackers <pdubqbdyi-bfkmicgiir3r.ml@ml.delegate.org> wrote:
 |Hello,
 |
 |On Wed, May 24, 2000 at 12:22:29PM +0900, Yutaka Sato wrote:
 |> On 05/19/00(00:48) you Heiner Lennackers <pdubqbdyi-bfkmicgiir3r.ml@ml.delegate.org> wrote
 |> in <_A797@delegate-en.ML_>
 |>  |I have problems with delegated after upgrading from version 5.9.3 to 6.1.10.
 |>  |The  6.1.10 always  resolves the  hostname to  an ip  address,  so i  cannot
 |>  |reach "virtual servers", with different  hostnames, but the same ip address.
 |>  |If I  disable the  resolving  of  the delegated,  it will  only  connect  to
 |>  |the addresses found in the local /etc/hosts file.
 |>  |What must i do to let it work properly?
 |> 
 |> Sorry but I'm not sure what is the problem.  Could you show me the
 |> parameters you gave to your DeleGate ?
 |i am using the following startup command:
 |
 |   delegated -P80 SERVER=http \
 |                  EXPIRE=1d \
 |                  CRON="0 * * * * -expire 2d" \
 |                  PROTOLOG \
 |                  RESOLV=dns \
 |                  REACHABLE="!www.skyinet.net,!206.101.197.226" \
 |                  RELIABLE=".localnet"
 |
 |Here an example what happens:
 |	if i ask the delegate for "http://www.rising-systems.com/" 
 |        delegate sends the request to the server using the ip address,
 |	but this is a virtual server. On the same physical server server 
 |        are some other http-sites too, e.g.  http://www.bytewurm.de/ . 
 |        The server uses the name to decide, so if delegate uses the ip 
 |        to address the server i never get a valid answer.
 |
 |On the pervious used delegated 5.9.3 i use the sme options except that
 |the server options is set to: SERVER=http://-/-/
 |If i use this option with the delegated 6.1.10 i get no answer at all.
 |
 |I hope you can help me with this.
 |
 |Thanks in advance.
 |
 |Heiner Lennackers
 |-- 
 |Dipl. Ing. Heiner Lennackers, lennackers@rising-systems..de, fon: -122  /"\
 |rising systems networks GmbH        GF: Sebastian Witzmann, HRB 35549  \ /
 |Achenbachstr. 43, 40237 Dâ…˛seldorf, fon: +49 000 000 000-F  fax: -489   X
 |ASCII Ribbon campaign against HTML E-Mail >- - - - - - - - - - - - - > / \



  admin search upper oldest olders older1 this newer1 newers latest
[Top/Up] [oldest] - [Older+chunk] - [Newer+chunk] - [newest + Check]
@_@V